actions on objects: user.get(), user.add(), post.modify(), post.delete()
user = new User(id)
posts = new Posts()
post = new Post(data)
Yeah, that works too! I prefer a more functional approach though, that's pretty much what I described :) this is more OOP.
But as long as you and any person who hasn't seen your code can read it, anything works!
I agree about use of English and naming things clearly, but having function that gets all posts just to filter one by author and modify it's title seems quite inefficient.
Also in last example variable posts is not actually defined and example before that posts is a function so posts.filter is also undefined.
I'm trying to say that details do matter in code.
Oops, thanks for pointing that out, I fixed it :) I'm used to the editor showing me wrong references.
This example isn't real and was just written for demonstration of all principles mentioned. If it were a post about efficient code, I definitely wouldn't have done that 😃
Thanks for the useful tips and easy to understand examples. :)
Great post, Jaff
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.