DEV Community

loading...
Jannis Jorre profile picture

Jannis Jorre

Professionally programming since 2017. Currently studying Software Engineering at CODE (code.berlin/). Full-Stack.

Education

Student at CODE (https://code.berlin/en/)

All 29 comments

Feature flags in React

This seems like an awesome product that I'll definitely try...

Should a button communicate the current state, the intended behavior, or both?

I have to agree for this case. I think "switch to FR" would...

Should a button communicate the current state, the intended behavior, or both?

I don't think the label for switches should change between ...

Should a button communicate the current state, the intended behavior, or both?

Oh, also: I don't think hover effects are enough. If someon...

Should a button communicate the current state, the intended behavior, or both?

I definitely think buttons should indicate expected behavio...

OKRs from a development team’s perspective

While I totally agree that it's highly unlikely it'll work ...

I need your feedback about a new programming language idea to improve its design.

I don't think the "less time to write" argument is so valid...

Recovering From jQuery

Just dropping in to say that you shouldn't use .innerHTML u...

Why I dislike GitHub security alerts? (and how to disable them)

Thanks for this post! I have two things that I want to tal...

I need your feedback about a new programming language idea to improve its design.

I have a very nit-picky suggestion: changing .len to .lengt...

OKRs from a development team’s perspective

Hm... Seems like a hack to me. Shouldn't the reduction of...

OKRs from a development team’s perspective

I don't have much experience with OKRs, but I'd be curious ...

Design Patterns in Web Development - #1 Command

Great work! I never really understood what exactly CQRS enc...

Things Nobody Told Me About Being a Software Engineer

To #18: Search for mutation testing - it's not exactly what...

JavaScript: Handling errors like Go

I got that - sorry if I wasn't clear enough, let me rephras...

JavaScript: Handling errors like Go

Is there a reason though?🤔

JavaScript: Handling errors like Go

Thanks for the post! I think this is a great pattern to fol...

Help test the DEV beta app!

Personally I prefer an optimized PWA over installing a nati...

Code splitting in React

Awesome article! Just want to note that the import() syntax...

Reified generics in Kotlin

The clearer names are more important than having to scroll ...

Reified generics in Kotlin

Thanks for this awesome article! This gave me some insight ...

Graveyard update: Human Bingo lives!

Well, the fp features exist in Java too, just to mention it...

3 Essential Components of Great Documentation

First of all, sorry for such a long silence, I've been mean...

The joy of streams

(1) I assumed it was because of a reason like that, but sti...

The joy of streams

You could even replace .filter(event -> event != null) w...

3 Essential Components of Great Documentation

I just want to clarify upfront: I didn't say no docs are ne...

3 Essential Components of Great Documentation

In my experience I have never come across a case where a co...

3 Essential Components of Great Documentation

I really like your approach to documentation. I have to dis...

loading...