loading...

"The response is not a valid JSON response" - and other things I don't get

mariel profile image mariel ・2 min read

HELLO FELLOW TRAVELERS OF THE INTERNET TUBES.

I've started working with WordPress as part of my internship (I'm in week 3; adventure!) and it's ... not n00b friendly.

But, because so many people use it, there are a lot of responses when you google why something isn't working!

My current project is building a custom Gutenberg block. Right now, I'm working with create-guten-block, but that's for another post.

For THIS post: I KEPT GETTING THIS ERROR AND I (STILL) DON'T KNOW WHY.

That screenshot is via Wordpress 786 because I derp'd and didn't take my own before fixing it.

DOCUMENT YOUR ERRORS, PEOPLE.

gif saying remember it, write it down, take a picture

The solution also came via Wordpress 786 --- Look on the left side of your screen and scan down until you see "Settings." On the menu that comes up on hover, click on "Permalinks".

Once that opens: don't change anything

Just go to the bottom and click "save."

Then, when you return to your post - poof the JSON error is gone.

https://media.giphy.com/media/3o7qE32pRVNYJYKGBO/giphy.gif

Why does that work? I HAVE NO IDEA. I'm at the "I just need things to work" level of using WordPress. Someone who actually knows: feel free to hop in the comments. I'll be here to give you a thumbs up.

https://media.giphy.com/media/XreQmk7ETCak0/giphy.gif

Posted on Jan 19 by:

mariel profile

mariel

@mariel

Software engineer! <3 Lawyer! I love dogs, cookies, and learning new things.

Discussion

markdown guide