DEV Community

loading...

Discussion on: Write better code and be a better programmer by NEVER USING ELSE statements

mcsee profile image
Maxi Contieri

Agreed with the standard part

I'm not suggesting replacing Helper with another standard.
I'm suggesting to change every helper to an intention revealing name according to the domain

in your case I think charitiesByCampaignAndCountry(campaign, country) is a very good name related to domain. But it is not a helper :)

Thread Thread
dglsparsons profile image
Douglas Parsons Author

I'm absolutely agreed with the names of the functions. Although I'd argue that as a concept, the function is still a helper 😜 (insofar as it's separating out the logical act of getting charities from the specific invocation of it).