DEV Community

loading...

Discussion on: Create a Fullstack Next.js App with Authentication, Data, and Storage

Collapse
weisisheng profile image
Vince Fulco

Think I've got the latest versions of everything but the following error surfaces...

wait - compiling...
error - ../../../node_modules/aws-sdk/clients/costexplorer.js:10:0
Module not found: Can't resolve '../apis/ce-2017-10-25.min.json'
null

Kinda cryptic and googling around doesn't raise any fixes. No idea why cost explorer would even need to be included in amplify Appreciate any tips/tricks others might have. TIA.

Collapse
aspittel profile image
Ali Spittel Author

Thank you so much for this feedback, can you copy in your requirements from your package.json by any chance? Seeing the versions you're using would be really helpful.

Collapse
weisisheng profile image
Vince Fulco

Thanks for the fast reply. I wasn't expecting you to debug for me ;-)

Ugh, I hadn't added aws-amplify properly. That's what I get for studying code late in the night after a full day of other dev. All good now.

Some comments have been hidden by the post's author - find out more