DEV Community

loading...

Discussion on: Installing Docker and Docker Compose on the Raspberry Pi in 5 Simple Steps

Collapse
ask_dba profile image
Alkin Tezuysal

My docker-compose step fails as follows;
Exception: Version mismatch: this is the 'cffi' package version 1.13.2, located in '/tmp/pip-build-mJ6FCD/pynacl/cffi-1.13.2-py2.7-linux-armv7l.egg/cffi/api.pyc'. When we import the top-level '_cffi_backend' extension module, we get version 1.9.1, located in '/usr/lib/python2.7/dist-packages/_cffi_backend.arm-linux-gnueabihf.so'. The two versions should be equal; check your installation.

Any help appreciated.

Collapse
ask_dba profile image
Alkin Tezuysal

sudo pip3 install cffi==1.13.2 solved but there are other dependencies.