DEV Community

loading...

Discussion on: You don't need express to get started with socket.io

Collapse
bgadrian profile image
Adrian B.G.

And most important, you do not need socket.io to start with websockets.

Collapse
sadick profile image
Sadick Author • Edited

Its true, you don't. But socket.io implements WebSocket backend and frontend with many fallbacks for probably every possible browser you can imagine.

Collapse
bgadrian profile image
Adrian B.G.

I know but you do not need that when you get started with real-time communication, which I presumed the topic is all about.

I'm pro learning the base technology first (vanilla web socket) then learn socketIO (which solve a few problems you will encounter in production).

Collapse
aghost7 profile image
Jonathan Boudreau • Edited

I think this generally isn't relevant anymore. Even IE implements websockets.

Thread Thread
sadick profile image
Sadick Author

IE implements Websockets from version 11. It only becomes irrelevant if you don't intend to support versions 10 and below.

Thread Thread
aghost7 profile image
Jonathan Boudreau

Not even Microsoft supports IE 10 and below anymore. If your company is supporting it, they need to look back at their policies because supporting a browser that hasn't been supported by its vendor since 2016 is a security risk.