DEV Community

loading...

Discussion on: Back to basics: Naming

Collapse
karloabapo profile image
Karlo Abapo

I prefer number 2 because it is specific to the context of returning true or false.

Number 1 isn't bad but it's more appropriate for doing more steps of validating the email other than true or false.

Collapse
sadick profile image
Sadick Author

What about number 3?

Collapse
karloabapo profile image
Karlo Abapo

emailIsValid seems to assume the email is already valid.

I try to be more specific when I write; keep the structure close to english or native language to avoid cognitive overload.