DEV Community


Discussion on: GraphQL Auth with Passport and Lighthouse PHP

madrobotno profile image
MAD Robot (Martin Agnar Dahl)

Hey Jose!
I am trying to install Your package but I receiving error message:
Problem 1
- joselfonseca/lighthouse-graphql-passport-auth[5.1.0, ..., 5.1.1] require laravel/passport ^10.0 -> found laravel/passport[v10.0.0, v10.0.1, 10.x-dev] but it conflicts with your root composer.json require (~9.0).
- Root composer.json requires joselfonseca/lighthouse-graphql-passport-auth ^5.1 -> satisfiable by joselfonseca/lighthouse-graphql-passport-auth[5.1.0, 5.1.1].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.
I use laravel 7.24

joselfonseca profile image
Jose Luis Fonseca Author

That is because it requires passport 10 and you are requiring 9, can you update to passport 10? it should fix the issue.