Skip to content
loading...
re: My big concern has always been what the Tabs Are Evil article calls "continuation lines". I think code like this (from that article) is ugly and ha...
 

Yes, exactly. If you wish to align things just start them all on the next line.

The space approach is entirely annoying, not because they're spaces, but because all functions have different alignments.

int go( int f,
        int y );

int somewhatLongerName( int f,
                        int y );

This sucks for readability, but also has a very real cost in maintenance and source control. If you wish to rename a function you have to modify the alignment of all the parameters again, this needless increases the patch size, thus wastes reviewer capacity.

code of conduct - report abuse