DEV Community

loading...

Discussion on: Tips on naming boolean variables - Cleaner Code

Collapse
nikitaargov profile image
NikitaArgov

Great article, thank you!

Found it, trying to find idea for naming of boolean "AreContactsShown". Name "isEachContactShown" would be weird - there are no separate contact items.

Any suggestions?

Collapse
crhain88 profile image
Christian

contactsAreShown, contactsAreVisible, or create an object: contacts.visible

Collapse
michi profile image
Michael Z Author

Thanks!

Where are the contacts displayed in? You could maybe use that instead, e.g. isContactListShown