DEV Community

loading...

Discussion on: Simple hook to deal with async function calls

Collapse
rafi993 profile image
Rafi Author • Edited

The initialResponse is just bad naming. I should have named it something else (but I could not think of anything at the moment). It is just the initial value I want the response state to have.

Collapse
rafi993 profile image
Rafi Author • Edited

all of this could also be tracked in a single state too. But I just separated it just to be explicit. Thanks for your feed back :)