DEV Community

loading...

Discussion on: GraphQL Auth with Passport and Lighthouse PHP

Collapse
ramirezfer772 profile image
ramirezfer772

Hola, a la hora de ejecutar composer require joselfonseca/lighthouse-graphql-passport-auth veo una incompatibilidad con laravel 6, hay planes para actualizar el paquete para laravel 6? te agradesco.

Collapse
joselfonseca profile image
Jose Luis Fonseca Author

Hola, podrías por favor crear el issue en el repo con el error para mirarlo, gracias!

Collapse
ramirezfer772 profile image
ramirezfer772

Hola, listo, ya abri un nuevo issue con el error. Muchas gracias.

Thread Thread
joselfonseca profile image
Jose Luis Fonseca Author

Hola, el problema era que tenias Passport 8 y ese aun no lo teníamos en las dependencias,

github.com/joselfonseca/lighthouse...

Intenta con ese release que ya debe funcionar

Collapse
malejandro13 profile image
malejandro13

Si funciona en laravel 6, pero debes instalar passport 7.5.1 o inferior, así lo deje yo de momento y gracias Jose Luis, excelente aporte :)

"require": {
"php": "7.2",
"fideloper/proxy": "4.0",
"joselfonseca/lighthouse-graphql-passport-auth": "2.0",
"laravel/framework": "6.2",
"laravel/passport": "7.5.1",
"laravel/tinker": "1.0",
"nuwave/lighthouse": "4.5"
},

Collapse
joselfonseca profile image
Jose Luis Fonseca Author

Gracias! igual ya soportamos Passport 8

github.com/joselfonseca/lighthouse...

Saludos!

Thread Thread
ramirezfer772 profile image
ramirezfer772

Hola, muchas gracias, te agradesco tu tiempo