Skip to content

re: Looping through objects in JavaScript VIEW POST

re: While I generally agree with the message here (using Object.keys(), Object.values() and Object.entries()), I wouldn't generally recommend using for...

it's generally easier to read.

I'd say this has more to do with your style, while I prefer these methods also, I've seen bunch of colleagues not understanding how these methods flow
it feels magical to them, they rather have a for-of (or a good old for) perhaps because my colleagues do tend to do more procedural stuff but y' know what works best for you is the way to go most of the time

but to reasure, I do prefer to use map, forEach, filter, and reduce when possible

code of conduct - report abuse