Looping through objects in JavaScript

Zell Liew 🤗 on June 27, 2018

Once in a while, you may need to loop through Objects in JavaScript. The only way to do so before ES6 is with a for...in loop. The problem with ... [Read Full]
markdown guide

Zell Liew, just wanted to add my 2cents to this well written article.

I feel if one realises that a particular object would require a lot of iteration then maybe they need to start thinking about ditching the object in favour of data structures which have a first party support for iteration.

With ES6 we have a new fancy data structure called Map and it is a perfect fit for those cases where you are overloading an object with thousands of properties and also want to iterate through them.

A simple example of Map.

var map = new Map();

map.set('random', 34);
map.set('abc', 42);

for(const val of map.values()) {

MDN Docs for Map


While I generally agree with the message here (using Object.keys(), Object.values() and Object.entries()), I wouldn't generally recommend using for of loop (or any for loop for that matter). It doesn't work well with immutable data. Using pure functions like Array.map(), Array.forEach() or Array.filter() is generally better idea - you don't have to deal with side effects and it's generally easier to read.


I totally agree with you regarding for loop and how .map, .reduce, .filter are a heavenly match for functional programming. But there are cases where I feel for of loop is a natural fit:

  • Iterator: Javascript now has native support for iterators (I talk about them in my article), so dealing with Map, Set, Array etc, the for of loop becomes a natural choice over converting these iterators to arrays and then applying the functional methods.

  • Async: Another area I find for of loop a rather easier read is when I have to iterate through an async collection. I talk about some examples of async for loop here.


it's generally easier to read.

I'd say this has more to do with your style, while I prefer these methods also, I've seen bunch of colleagues not understanding how these methods flow
it feels magical to them, they rather have a for-of (or a good old for) perhaps because my colleagues do tend to do more procedural stuff but y' know what works best for you is the way to go most of the time

but to reasure, I do prefer to use map, forEach, filter, and reduce when possible


Under the "Looping through the array" section, in the first code example, you have:


This should be key, not keys:


Nice and concise...very helpful thank you

code of conduct - report abuse