var hasGoodPoint = true;
var isMyConvention = true;
Also, I prefer not to pass booleans to (typically multi-argument) functions unless they are obviously expecting true or false (ie. property methods), so typically "can" or similar named functions:
This is okay:
But this is not so good:
Some languages have named arguments, so in that case it'd be better to say:
Alternatively use enums:
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.