DEV Community

loading...

Discussion on: Configure your Mac for Java Development

Collapse
khmarbaise profile image
Karl Heinz Marbaise

Hi, can you explain me the part: We must use at least version 3.5.0 (the current version is 3.6.3), ? Why not using the most recent version? I strongly recommend to use the most recent version of Maven..

Collapse
guyghost profile image
Guy MANDINA Author

For compatibility reason, you need to use at least Maven 3.5.0 and Maven Compiler Plugin 3.7 with Java 9. If you want to go further and use the most recent version of Java you can go on the last version of Maven.

Collapse
khmarbaise profile image
Karl Heinz Marbaise

Maven is not needed to update it works with all JDK version. What is correct to upgrade Maven Compiler Plugin to most recent version (3.8.1).