DEV Community

loading...

Discussion on: A coding interview question asked at Google

Collapse
llcamara profile image
LLCamara

Small code review regarding the solution: I would refrain from using the term "pointers" - both on explanation and implementation - since the solution does not use actual pointers. Suggestion: rename to pivots (or indexes) instead.

Collapse
elisabethgross profile image
Collapse
byrro profile image
Renato Byrro

Agree, most appropriate term would be index. Pointer reminds me of memory allocation.