range is a function that basically takes in a starting index and ending index then return a list of all integers from start to end.
The most obvio...
For further actions, you may consider blocking this person and/or reporting abuse
I like this way:
As array from works with arrayLike structures and receives a second optional argument mapFn, it's a nice candidate to build range.
Yes, excellent solution.
This, slimmed down, version also works...
Almost.
Try:
as satisfying as this is, you're exposing a third argument that anyone can override. In a modern tech stack, this code is hesitantly admissible only if you can guarantee that absolutely no one can set
length
to be anything butend - start
, otherwise you need to invest in a much more complex testing framework, likely outweighing the expense of adding a second line to this function.const range = (start, end) => Array.from({length: end}, (_, i) => start + 1);
Sorry kerafyrm02, but that does not produce a range.
If I run range with range(1,50) I get [2,2,2,2,2,2,2,2,...]
const range = (start, end) => Array.from({length: end}, (_, i) => start + 1); console.log(range(0,20))
let r = (s, e) => Array.from('x'.repeat(e - s), (_, i) => s + i);
Ok here ya go... even shorter. :D
Rock, paper, scissors... 68 chars, you've nailed it!
lol., made
range
tor
.. so even shorter :DTrust me to bump into a js golfer.
Next you'll be telling me that you're dropping the let keyword and just leaving r on the global object!!
haha! nice solution John!
Well, thank you so much for saying!
Hi All, I'm trying to grasp this function:
But I still confused on why does passing { length } as first argument in Array.from is work to create new array with specific length.
Because what I read in the documentation about Array.from is only works for iterable or array like object.
Any explanation or help would be appreciate a lot. Thank you.
This is how I went about creating a different solution although it is only really beneficial by calling (value in target) and really only counts as a "typeof range" :) Just bored and playing around with proxies.
If you're going to use => might as well go all in... (line break for readability on dev.to)
const range = (start, end) => new Array(end - start + 1)
.fill(undefined).map((_, i) => i + start)
I am quite against writing all functions as arrow functions. The reason being that arrow functions are not bind-able and it refers to the
this
from the outer scope. I feel that it is designed to prevent us writingvar self = this;
and refer toself
in a callback function. So I tend to write arrow functions only when it is a callback or when it is a one-off function. Also if we use arrow function instead of proper function declaration in this case, we will lose the advantage which function hoisting provides. This meansrange
might not be accessible by some earlier parts of our code. But it is all down to personal preference, do tell me what you think.I don't like ambiguity in code. When I'm reviewing code and have to stop and figure out what this is referring to, it makes me frown; with arrow functions I always know exactly what this is. The 'swap this and that' pattern in JS always struck me as a hack. One of the big wins of arrow functions is eliminating the this ambiguity.
I have a similar feeling for hoisting. I understand why it is part of the language, but it always feels like a path to ruin when I have to rely on some behind-the-scenes reshuffling by the interpreter to get my code to run.
All that said, you are correct that there are situations in which arrow functions are not appropriate, which also make me crazy. Having two ways to write functions just adds confusion. "We recommend using arrow functions everyhwere. Oh, sorry, was that a constructor? Write that one this way instead..."
I can't wait to start seeing code in review that's built with templated classes. Maybe ES7 will introduce header files...
Haha! I totally understand what you mean. But still since ES6 introduces
class
we should really move away from usingfunction
as a constructor. As soon as it is consistent in a team then it's fine.Also, I'm a big fan of using variable names that describe what they are (even for internal functions), so (line break for readability on dev.to)
const range = (start, end) => new Array(end - start + 1)
.fill(undefined).map((value, index) => index + start)
On the other hand, I am a big fan of Haskell. And we tend to use
_
to refer to variables which we don't use in the function. But I do agree with you that having meaningful names is a good practice and could help readability.Even in Haskell, _ is a bad idea :) Think about the poor intern trying to learn the language while debugging your code. (And it isn't just Haskell...I did a lot of Perl back in the day, which at it best can look like line noise).
BTW since you are a fan of Haskell, I ran across this article the other day that you might enjoy, describing how to structure JS function with Haskell-styl currying.
I liked your recursive generator. How about something like this:
This is great, I wish this would make its way into the spec.
Haha! I like this idea!
This is an Awesome string of code you've written. I'm partial to Python3 behavior of range though. Made a few minor adjustments yours. Better to steal like an artist then build from scratch.
The recursive one is really nice. Can be shortened to:
Also this is another approach, + easier to handle descending sequences too:
I'm a little late for the discussion 😅 but I found the different ways interesting, I ended up getting this one. Is it valid?
Looks great to me!
I just use a one-liner recursive arrow function in ES6; note, it doesn't check but you should only pass it integers else it will never get to a == b so it will blow the stack!
Are you actually using this in production code? 😂😂
You realise how inefficient this is right? 😂😂
I have adapted Namir's method (see comments). And it is probably the most efficient.
Why not get really wild and crazy :P ?
1st define a unfoldr
then define a range in terms of unfold
excellent article btw, keep them coming :)
Why nobody is wondering why this is not part of the standard library?
php.net/manual/en/function.range.php
ruby-doc.org/core-2.5.1/Range.html
docs.python.org/3.3/library/stdtyp...
It rather depends, Jason, on what you mean by cooler.
If you only needed range to handle approx. 6000 iterations then I think a recursive range function is pretty cool, but slow:
But, if you need a much bigger range and fast executuion then do something like this:
And if you don't like the arrow function, then it's easy to convert to a standard es5 style function.
Might be inefficient to create an array for large ranges, and only supports range of integers (no dates). Have you seen Ruby's Range class? ruby-doc.org/core-2.2.0/Range.html
You could still implement toArray() and offer a covers() function.
Yes! You are right! I will add a generator implementation as well which should solve this problem! ;D
I'd like to see the generator implementation!
What do you think about it? I have implemented.
The for loop is by far the easiest to read and also by far the most efficient. Your last example was literally more than 15 times slower than the for loop. Far too many developers these days are trying to get all fancy when the simple solution is much better.
Thanks for this article. I find your first answer to be the most intuitive, and it works great for my situation.
After reading through this helpful discussion this what I came up with, I added a condition if the start point of the range is greater than the end point. This my very first contribution
😉🤩✨✨✨
☝️ is what i was looking for. tweaked it slightly:
let's go both ways!
oooooo maybe with
Math.sign
?Python world has experimented with creating the whole array vs generator. They landed on the generator. In Python 2 they have range for whole array and xrange for generator. In python 3 they dropped the array all together and use range function to return a generator.
Or one-liner:
Thanks bro, it was helpful.
Like this:
[...Array().keys()];
this way you get the range from 0 til -1
I think this code is not going to work with float values. like generating a range like [0.01, 0.02, 0.03 ...]
Jason, just curious, what's your concern about looping? I don't have a reference, but I would think that the various interpreters (especially V8) would optimize / unroll them.
It's just personal taste I guess. I think code with less loops are more readable.
Good job
What does _ meant in map function?
Just a variable name. Has no special meaning to the language.
Mayby it have no special meaning, but it's commonly used to signalise unused argument or variable.