We definitely need to bring back Apps Hungarian!
The mangled twin, Systems Hungarian (i.e. intCount or boolIsRaining), is the madness that most people object to. That's where you use the data type as the prefix, and it helps no one. Please, for the love of all things digital, don't use Systems Hungarian!
Incidentally, I do use an odd little version of Hungarian Notation in GUI design. Every time I create a widget, I use a prefix relating to the widget type. It's something of a hybrid between Apps and Systems Hungarian, but it helps me avoid confusing widgets when writing code. For example, chkSubscribe would be a "Subscribe To Emails" checkbox, whereas btnSubscribe would be a "Subscribe" button - which might both have uses in a single interface (albeit a rather weird one, but hey, it's a rough example). Honestly, that's the only place I even come close to Systems Hungarian.
We’re a place for programmers to stay up-to-date, learn new skills, and share ideas.
We’ll never post without your permission.