DEV Community


Discussion on: Stop Using "data" as a Variable Name

mchaitanya profile image
Chaitanya Malireddy

Great ideas but I wouldn't replace i with accountIndex. That doesn't add much value - it's a common convention to use i as a loop counter.

Also I think this is a good rule of thumb:

The length of a variable name should be proportional to its scope.