re: Configuring Circle CI 2.0 for a Real Rails Application VIEW POST

VIEW PARENT COMMENT VIEW FULL DISCUSSION

I'd be interested in trying this in the future though I really, really think that it would not fix the problem we had whereby when yarn is installed from a remote script the remote script would return invalid content or a 4x/5x error.

This dependencies key was part of Circle 1.0 and we actually used it there, but under Circle 2.0 the dependencies key is not documented as far as I can see (circleci.com/docs/2.0/configuratio...).

The image you're using will have yarn pre-installed (circleci.com/docs/2.0/yarn/) and because you're not checking its version I could see that your configuration might not even install yarn but use the image's pre-installed version which would circumvent completely the issue we had to fix.

My thoughts on why you would not have experienced the issue we did was because you're not installing yarn but using the image's version.

code of conduct - report abuse