Cool stuff. I would name it by looking at what it does functionally, not methodically. So I would name it this way, something like: propertyPath, extractPath, accessMap.
Nice approach, I was thinking about it a bit, but couldn't come up with any good ones.
Is there any reason not to pluralize it, like: extractPaths?
Yeah you could do that sure.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.