Skip to content
loading...

re: Invert your ifs! VIEW POST

TOP OF THREAD FULL DISCUSSION
re: The true term is actually called guard clause : medium.com/@scadge/if-statements-d... And as we don't nest conditions, it is not a pyramid, it is ...
 

That's true. I’m familiar with the term ”guard clause”. It’s a part of defending coding style :) To be clear, I have nothing against guard clauses, I use them very often, sometimes I extract them to separate class to split validation logic into a separate piece of code. To keep the code clean, we can't nest if statements. As you said ”flat” construction is not bad, but the pyramid is, in my opinion, the pure evil.

code of conduct - report abuse