DEV Community

loading...

Discussion on: Sh*tpost: can we stop saying "syntactic sugar"?

Collapse
ryansmith profile image
Ryan Smith • Edited

I don't use the term myself, I call it by the feature name (like async/await), "the new syntax for _", or "the improved syntax for _." I just call it what it is instead of trying to dress it up.

I think it is one of those terms that is picking up in usage recently, especially in the JavaScript community. I think that leads to a tendency of muddying the original intent and having it be applied to everything new added to a language.