While that's better it still creates clutter in your object. A default inspect will show @h = ... even though that's not really relevant to that object. There's no reason to create this per-object, either, it doesn't change. That's why I recommend as a constant, out of the way and implicitly shared.
@h = ...
Also remember that months have commonly recognized numerical identifiers, there's no need to say "feb" when 2 will do.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.