DEV Community

Discussion on: Yarn 3.1 🎃👻 Corepack, ESM, pnpm, Optional Packages ...

Collapse
shinigami92 profile image
Shinigami

I tried nodeLinker: pnpm instead of nodeLinker: node-modules, but I'm getting many errors like Cannot find module
But the modules are sub dependencies, so why should I require them to have them explicitly set in my own dependencies? I don't want to configure hundreds of dependencies when they get already declared as sub dependencies in the relevant packages

So what can I do to tell yarn that it should read the symlinks correctly?

Collapse
devinrhode2 profile image
Devin Rhode

Is there a hard links option that might work? Are you on windows?