DEV Community

William Cairns
William Cairns

Posted on

Moving to create-react-app ver 5.0.0

I hate it when someone changes the ways things have been done, and then does not give enough information to move to the new way :(. Create React App has just done this with the upgrade to version 5.0.0

If you try create-react-app with an older version 4 installation you get the very helpful message:

You are runningcreate-react-app` 4.0.3, which is behind the latest release (5.0.0).

We no longer support global installation of Create React App.

Please remove any global installs with one of the following commands:

  • npm uninstall -g create-react-app yarn ...`

So I naturally went ahead and did the uninstall :(

`npm uninstall -g create-react-app

up to date, audited 1 package in 488ms

found 0 vulnerabilities`

It didn't uninstall the old version, it just did an audit instead. (I assume there are dependencies installed on the version 4 library.

I tried to reinstall create-react-app and flushing the cache - both with and without the -force option. I could not get a new project created.

Finally I had to force install the latest version
`npm install create-react-app@latest
npm WARN deprecated tar@2.2.2: This version of tar is no longer supported, and will not receive security updates. Please upgrade asap.

added 67 packages, and audited 70 packages in 9s

4 packages are looking for funding
run npm fund for details

3 high severity vulnerabilities

To address all issues (including breaking changes), run:
npm audit fix --force

Run npm audit for details.`

And finally I could successfully do a create-react-app.

PS. Yes, I did do a fix on the vulnerabilities.

Discussion (2)

Collapse
rangercoder99 profile image
RangerCoder99

This none support global installation is already there from version 4! Run into that issue many times all that was needed for the npx command to work is clearing the cache of both yarn and npm