loading...

Error "Dart SDK not configured" al importar un proyecto de Flutter desde git

mdev88 profile image Martín Vukovic ・1 min read

Síntomas

Si se encuentran con este error, es muy probable que sea porque están usando Android Studio y no han configurado correctamente (o en absoluto) el SDK de Flutter (Si, de Flutter, no de Dart).

Otro signo del mismo problema es que cada vez que crean un nuevo proyecto de Flutter, tienen que especificar manualmente la ruta al SDK de Flutter.

Solución

Acceder a File > Settings > Languages and Frameworks > Flutter e indicar la ruta al SDK de Flutter en Flutter SDK path.

Flutter SDK path settings

En mi caso, uso Ubuntu 20.04 e instalé el SDK de Flutter mediante snap, por lo que mi ruta es /home/usuario/snap/flutter/common/flutter.

Luego de aceptar los cambios, abrir el archivo pubspec.yaml y tocar en Pub get

Pub get

Luego, abrir cualquier archivo .dart y actualizar las dependencias tocando en la notificación de la parte superior del editor.

Get dependencies

FINALMENTE, porque aparentemente todavía es 1995, cerramos el proyecto y volvemos abrirlo y las notificaciones y errores (relacionadas con este problema) deberían desaparecer.

Posted on by:

Discussion

pic
Editor guide