loading...

re: Semantic Versioning using npm VIEW POST

FULL DISCUSSION
 

According to semver docs

^0.2.3 := >=0.2.3 <0.3.0

That means npm update won't pick 0.3.0 or above.
However this behavior is different when version is
^2.0.0, in this case npm will pick 2.999.999 but below 3.0.0

Code of Conduct Report abuse