maybe a softer approach, by reverting the php7.2 requirement (which is maybe not even required) instead of removing php7.1 from the matrix, would save some people from trouble (in this case it is not that problem because its and independed full app)
the rush for new versions it is really terrible for people which use the lts version of symfony. even 4.4, which was released a short time ago, only requires php 7.1
of course i know that people should update because php 7.1 is not supported any more but to be realistic, people still use php 5.6 because their apps are not compatible with higher versions and there is no time and/or budget to upgrade the app. Rasmus Lerdorf on phpday 2019 Verona May 10-11th, asking his audience who is using php 5.x (watch at least min 26:08-26:45)
as far as i know debian (i only found info about ubuntu after a quick search) also backports php security fixes for their supported releases. stretch ships with php7.0 and debian stretch is supported until june(?) 2020. lts for debian stretch runs until june 2022.
maybe such things should be included in a decision if a php should be removed from the matrix or not. a similar comment i made at codeception :)
please don't get me wrong, thank you very much for your awesome work, i love the flex server as symfony sadly decided not to opensource theirs or make private recipes possible without gibhub or without the need of installing a github app.
with this comment i just want to aware developers that removing, even outdated versions, can really make people struggle but of course its your decision which version of php this app should support.