Interesting take on it. I always think you should start the name of the function with a verb but didn't take it that far. It does sound reasonable.
I'm sure there was a post about Factory/Manager/Something-er classes on here... can't find it at the moment.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.