if thing_is_false would be better of course.
It depends on context of course, but in general I tend to disagree. Keeping booleans as the "positive" form seems to make things easier.
I really like to use unless for checking state and arguments at the beginning of methods:
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.