DEV Community

Discussion on: Asynchronous Calls, Data-Transfer-Objects & Automapper in .NET Core Web API

Collapse
 
henkvandergeld profile image
henkvandergeld

Hi Patrick,
Very good article. I have a suggestion for the naming of the Dto's. Instead of putting the verb at the beginning, like 'AddCharacterDto', I would write it like CharacterAddDto. You could then say: it's an AddDto for Character. This could also be applied for 'GetCharacterDto' by naming it 'CharacterGetDto'. So a GetDto for Character or CharacterUpdateDto, for an UpdateDto for Character.
The naming approach is also in line with CharacterController and CharacterService.
regards,
Henk

Collapse
 
_patrickgod profile image
Patrick God

Hi Henk,
Thanks for sharing that. Good point! :)
Take care,
Patrick