Mmm.. interesting philosophical topic. I really need to think about it. Thinking here now. I would say that it's a workaround, which is the appropriate solution for the situation (as opposed to refactoring the original function, which is not possible).
Keeping it in mind and in comments as "workaround" should potentially push more towards the "real" solution when it becomes possible.
I guess "workaround" is specific type of solution in this situation. Between two words when one is more specific, I choose the specific one unless I specifically want to generalize.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.