DEV Community

Discussion on: What's the worst part about the JS ecosystem?

Collapse
jcayzac profile image
Julien Cayzac

package.json and require().

PNPM now has support for package.yaml but half of the npm modules insist on parsing a package.json, preferably with a JSON parser from the early 2000s that doesn't support JSON-with-comments or trailing commas. Just give us an import.meta.moduleInfo(packageName) to get the package information already.

require() is completely broken but at least it's almost dead now.

Collapse
jcayzac profile image
Julien Cayzac

What makes you roll your eyes up to the sky?

And yes, having to deal with JSON in 2021 keeps me up at night.