DEV Community 👩‍💻👨‍💻

mark vachi
mark vachi

Posted on • Updated on

php7.1-gd ใน docker หาย ก็มาใช้ php7.2-gd ได้เหมือนกัน

ต้องใช้ php7.2 เพราะ php7.1-gd หาไม่ได้แล้ว แก้ที่ phpdocker/php-fpm/Dockerfile ตามนี้

# use php7.2-fpm
FROM phpdockerio/php72-fpm:latest
WORKDIR "/application"

# install php7.2 extensions for laravel
RUN apt-get update; \
    apt-get -y --no-install-recommends install \
        git \ 
        php7.2-bcmath \
        php7.2-gd \ 
        php7.2-imap \ 
        php7.2-mysql && \
    apt-get clean && \
    rm -rf /var/lib/apt/lists/* /tmp/* /var/tmp/* /usr/share/doc/*
Enter fullscreen mode Exit fullscreen mode

Top comments (0)

🌚 Friends don't let friends browse without dark mode.

Sorry, it's true.