The phrase - "mutation" started to have almost negative connotation in our programming community. It's like something wrong to mutate. As if we mut...
For further actions, you may consider blocking this person and/or reporting abuse
Can't agree more! We should think logically about our software logic and not follow some patterns blindly. 😌
Couple of thoughts while reading this excellent article Maciej:
Hi Phil,
Thanks for the comment.
Extending function is not a common practice in FP. We more should strive for small replaceable units. Instead of adding new use cases to the unit we should compose it with another. Until we keep them small even imperative code should not be any issue.
Again the same counter argument from my side. Until we keep functions small with one responsibility, nothing like that should happen.
Be wary of people who tell you you are just plain "wrong". Usually they just wish you were wrong. I fully endorse your views in this article - they are telling of someone who likes functional programming and wants to get sh*t done.
OO is OK.
FP is OK.
Java is OK.
Kotlin is OK.
Everything is OK if it gets the job done heheh.
Just saw your series and made some suggestions
Java is literally not OK. xD
(just kidding)
There's always one xD
Nice syntax and a feeling of "doing the right thing" lead to very inefficient code when it comes to immutability. This is a very nice article - I took a look at the costs of immutability in tight loops and code myself (which is another lens on this subject):
Tight Code 1: When immutability goes bad
Mike Talbot ⭐ ・ May 27 '20
My take on this - if the 'feels right' / 'elegant' solution isn't performant, then the language may have a problem - one of the reasons I like Python, the 'right way' is usually pretty quick too!
There is certainly a lot more sugar in JavaScript these days, and it's not always good for you ;)
Most modern languages with immutability implement it with persistent data structures, ClojureScript for example, deep efficient immutability is the default
The closest thing you have to persistent data structures in JS is ImmutableJS, though honestly once you've cobbled together rambdajs, react, ImmutableJS, Google Clojure Compiler you should just use ClojureScript
I have experienced that some devs love to write huge functions that span multiple pages. Which is something that is not ok for me. It might be convenient to just add to an ever increasing scope to never juggle state from one function to another, but it quickly becomes opaque which variable is mutated at which point or re-used somewhere else along the pages of code. So the rule of "mutation is ok within the same function" depends on how absurdly you stretch the rules, or in that case the function.
If it is compact, then maybe. But most of the time I prefer a re-usable function that you can apply to a
map
instead of writing a for loop that collects some data.FP has the promise of a declarative style that should make it more readable. Sometimes that is true, when you know what the words mean:
or better:
It needs some setup, but once you have the function assembled, you don't need as much boilerplate than with
if
andfor
statements EVERY TIME you use it. that is the entire point of FP. You can compact a lot of behavior into one function, give it a fitting name and re-use it as much as you want.vs
Ok, to be fair, we can apply at least the
isOddNumber
function within theif
condition.What bugs me the most, is that all these imperative statements (if, switch, for) always come with their own boilerplate. If you work on the result of
getOddNumbers
you have to do afor loop
once more, which adds to the boilerplate.I know why I do FP and I know why state mutation and statements are most oftenly not ideal to express your desired computation or behavior.
I would just answer - it depends. We state our opinions, in contrary to you I see also problem in extending dictionary for such simple cases, in my experience creating so many one liner function can end in ton of functions which nobody will use because they just prefer to write them inline. The example which shows that is famous
id
function, I personally prefer to just usex => x
than importid
from magic utils, it is just too simple.As having functions and composing them is a good thing, we need to take into consideration that more one liners mean also more jumping over the code. I was writing Elm for a while and I found myself in preferring using inline
if
expressions, or inlinecase of
instead of constantly creating new function. As I loose eye contact with what is really going on, and having many functions force me to jump through them. And no, readable name not always is enough to say that we never want to see what is going on.Also when I see this:
It is 🚩 for me, as this is nothing more like duplicating the already existing tools, such function in my opinion has no value, and even worst introduce smth which is additional in the codebase. So for me your first implementation:
is better, and probably I would even wrote that in that way, but this example is simplified and doesn't shows the whole picture.
I don't force anybody to use mutation, I am just saying that it is fine to mutate locally, it is fine to use "for" loops, nothing wrong with that. Of course if we just reimplement
map
orfilter
then we should think twice. But if function makes more than that, transformation for example needsreduce
then reaching for loops is fully ok. I don't feel pain looking at statements, also "boilerplate" can happen with expressions, Elm is famous for having a lot of boilerplate, even though it has no statements at all.And yes I prefer expressions over statements, but I in the same way I hate ternary expression and prefer if statement, as it is just more readable. Python has
<expr1> if <conditional_expr> else <expr2>
and this is awesome. But in JS, nah, ternary is really not nice.Generally i choose whatever code is more readable. Readabillity over performance is generally a good rule. Unless you get a meaningful performance drop that actually impacts the application, or alredy when making it know that the code will be executed constantly many times a second, readabillity is king in my book. Generally i prefer the code i dont need to understand. If the method signature is enough, i prefer not looking too much into the implementation. If the implementation is nice clean english such as users.filter, i won't have to give the rest a detailed read to feel comfortable using or changing it. You should understand the code enough that you arent putting gibberish into your codebase of course, however the best code is the one you can understand without reading it.
Nice topic of discussion. I liked it.