DEV Community

loading...

Discussion on: FLUTTER WEBVIEW TUTORIAL #1 - Convert a website to an app using flutter.

Collapse
mjablecnik profile image
Martin Jablečník • Edited

Why you are not using official webview_flutter package instead of flutter_webview_plugin where is not very big update activity for last 1 year? github.com/fluttercommunity/flutte...

Collapse
techwithsam profile image
Samuel Adekunle Author

This tutorial is in series, this is the first article on this topic latter in the series the official package will be used. Thanks for the info

Collapse
mjablecnik profile image
Martin Jablečník

So when you will use the official package in next series so why in the first article use some other not actively maintained package?
I don't understand it..
My opinion is that into tutorials we should use only active maintained packages otherwise it doesn't give a sense..

Thread Thread
techwithsam profile image
Samuel Adekunle Author

Well, flutter_webview_plugin is also an official package and I preferred it then to webview_flutter, because the first time I tried this package (webview_flutter) it has a lot of errors, that was long ago though, and that was the reason I started using flutter_webview_plugin.
The two packages achieve the same thing so it makes sense to me. Thanks

Thread Thread
mjablecnik profile image
Martin Jablečník

flutter_webview_plugin is not official package but it is community package.
webview_flutter is official package from flutter.dev team and support also null safety right now so you can use it in the newest Flutter version and Dart SDK.

Thread Thread
techwithsam profile image
Samuel Adekunle Author

Yeah, I know and I already answered you in the first place, this tutorial is in series and I will surely use the official package before the end of the series.
I have published this articles long ago on my medium and hashnode account am just resharing it here, so am not just writing this article am only just sharing it to this platform which I will update the series with the official package. I hope you understand. thanks