loading...
re: because IMO that's not more elegant. I think guard clauses should live in the if statement that has nothing to do with the rest of the code. I th...

Mm, Jason's version looks more readable to me. It's laid out a little more like you would if you were matching patterns in Haskell or something.

Code of Conduct Report abuse