DEV Community

Discussion on: You don't need --save anymore for NPM installs

Collapse
pawandeore profile image
pawan deore

can some one please explain me difference between --save and --save-dev

Collapse
727021 profile image
Andrew Schimelpfening

Packages installed with —save-dev are only for development. In a production environment, they won’t be installed. You usually install things like linters, compilers, etc. as dev dependencies, since you don’t need them in production.

Collapse
pawandeore profile image
pawan deore

Thanks for explanation. so just for clarification i will -> npm i bootstrap@latest --save

Thread Thread
727021 profile image
Andrew Schimelpfening

Yeah. But --save is also the default, so you can leave it out.

Thread Thread
pawandeore profile image
pawan deore

Thanks. hey we are going to change our frontend stack and SEO is main factor so what do you recommend Gatsby or NExt js (the backend is going to be php based ZEND framework's API's) and you can consider our website has blogs where content writers write blogs daily (we have builtin platform for that) also video viewing subscription based platform just like udemy so this is all we got on website so what do you recommend

Thread Thread
727021 profile image
Andrew Schimelpfening

I haven’t used Gatsby, so I can’t really compare the two.

Thread Thread
killshot13 profile image
Michael R.

Pawan, you should check out StackShare, it is a great resource for these types of architecture/stack comparisons unlike SO which mostly features on use-case specific solutions. 👍

stackshare.io

Collapse
wintercounter profile image
Victor Vincent

Just like npm.

Collapse
dailydevtips1 profile image
Chris Bongers Author

Thanks for this great explanation Andrew! 🙏