DEV Community

loading...

Discussion on: Create & Deploy Azure Function ⚡ using VS code and Azure DevOps (CI/CD)

Collapse
usmslm102 profile image
Usama Ansari Author

Can you post the complete error message. If possible please dm me on Twitter.

Collapse
shajay99 profile image
ajay sharma

Sir, on twitter, i could not send all text.

Build started 11/17/2019 10:44:54 AM.
Project "d:\a\1\s\Hermes.sln" on node 1 (default targets).
ValidateSolutionConfiguration:
Building solution configuration "Release|Any CPU".

[error]d:\a\1\s\Hermes.sln.metaproj(0,0): Error MSB3202: The project file "d:\a\1\s..\Hermes.Test\Hermes.Test.csproj" was not found.

d:\a\1\s\Hermes.sln.metaproj : error MSB3202: The project file "d:\a\1\s..\Hermes.Test\Hermes.Test.csproj" was not found. [d:\a\1\s\Hermes.sln]
Project "d:\a\1\s\Hermes.sln" (1) is building "d:\a\1\s\Hermes.csproj" (2) on node 1 (default targets).
PrepareForBuild:

Thread Thread
usmslm102 profile image
Usama Ansari Author

It seems you have deleted the test project but the reference is still there in solution file. If you delete the project from file explorer you have to remove the reference from solution file as well. If you can provide me more details the project structure and the build yaml file I can help you more on this.

Thread Thread
shajay99 profile image
ajay sharma

Usama Sir, Request you to please check if the stages of the Pipeline is OKay, as now all the stages are passing. And here it the YAML file. sorry the formatting is not OKay.

trigger:

  • master

pool:
vmImage: 'windows-latest'

variables:
solution: '*/.sln'
buildPlatform: 'Any CPU'
buildConfiguration: 'Release'

steps:

  • task: NuGetToolInstaller@1

  • task: NuGetCommand@2
    inputs:
    restoreSolution: '$(solution)'

  • task: VSBuild@1
    inputs:
    solution: '$(solution)'
    msbuildArgs: '/p:DeployOnBuild=true /p:WebPublishMethod=Package /p:PackageAsSingleFile=true /p:SkipInvalidConfigurations=true /p:DesktopBuildPackageLocation="$(build.artifactStagingDirectory)\WebApp.zip" /p:DeployIisAppPath="Default Web Site"'
    platform: '$(buildPlatform)'
    configuration: '$(buildConfiguration)'

  • task: VSTest@2
    inputs:
    platform: '$(buildPlatform)'
    configuration: '$(buildConfiguration)'

Thread Thread
usmslm102 profile image
Usama Ansari Author

Build pipeline looks ok. There might be the issue with your solution file. You might have a reference of "Hermes.Test.csproj" in your solution file but the actual csproj file doesn't exist.

Thread Thread
shajay99 profile image
ajay sharma

Thanks Usama Sir.. thanks for guiding me..
Sir, in my pipeline, PUBLISH and PUBLISH ARTIFACT are not visible. Have I selected wrong template ??