re: Code Smell: No AND in Function name VIEW POST

TOP OF THREAD FULL DISCUSSION
re: Great article! Especially when doing database operations I quickly find myself naming my methods/functions something like this: findPostRecordsWh...
 

I might be missing the obvious, but couldn't you just do:

findPostRecords({ userId, status })

If you're using Typescript/Flow (or Eslint to some degree, but I have to check), the arguments would be shown in your IDE so that you would know them when you type them, without having the need to be part of the function name.

 

That works well when you always have the same criteria for finding post records. However, once you have to fetch post records under different conditions you need to overload (which is messy is not so cool in js).

Nevertheless, I can see how your approach could work for projects that are not too big!

You don't need to overload. Just make the function take a single object as an argument with optional properties, then filter out the undefined ones at the start.

This becomes a mess when only certain object properties should be used together.

code of conduct - report abuse