DEV Community

Discussion on: Ruby Segmentation Fault When Running RSpec

Collapse
katafrakt profile image
Paweł Świątkowski

MacOS is actually notorious for breaking Ruby-related things on every upgrade, so you might be on to something. Just last week my colleague had to reinstall his system completely in order to make Ruby working again. He had other symptoms though, as far as I remember (something SSL-related).

Thread Thread
andy profile image
Andy Zhao (he/him) Author

Yikes. I'm going to be wiping my drive anyway, so while drastic, it might solve my issues. Maybe 2.5.1 will fare better with High Sierra, too.