Good call! I’ve seen several recommendations for using is/has in Boolean variable names.
Well, is/has is a convention. In Ruby it is common to use "question mark" instead.
But, more importantly, I would not use an imperative verb to name this boolean variable.
Imperative would more appropriate for methods (or functions) that have side effects. In this case, you are using the variable to store the result of a computation.
We're a place where coders share, stay up-to-date and grow their careers.
We strive for transparency and don't collect excess data.