Installing Docker and Docker Compose on the Raspberry Pi in 5 Simple Steps

Rohan Sawant on October 12, 2019

You know what Docker is. You know what a Raspberry Pi is. Let me make sure they hit it off together. ๐Ÿ˜Ž๐Ÿค๐Ÿฝ This is probably one of the quickest and... [Read Full]
markdown guide

It seems a problem with the docker python client. After running docker-compose for the first time. You get the error ImportError: No module named ssl_match_hostname on init

The fix is cp -r /usr/local/lib/python2.7/dist-packages/backports/ssl_match_hostname/ /usr/lib/python2.7/dist-packages/backports


this might be a better option.

sudo apt-get remove python-configparser

After removing configparser docker-compose starts as expected.
I removed after installing compose via pip but noted an error related to configparser at end of install so this might be better run after dependencies but before compose. This part I haven't tried


Hmm, this is weird did you try to install it with Python 3?

Python 2 support ends next year.

Update, in the next few weeks, I'll rewrite this and try again on a fresh installation that should help me find the errors.


I was just using the standard installers as listed in your instructions (which are great BTW). Everything from first glance still uses Python2.

Yeah, you are correct, I just re-read my own post and yep everything seems to be using Python 3 ๐Ÿ˜…

Please disregard my last comment.

I'll update the post and fix the remaining issues soon, that should help with my confusion.

Just out of curiosity how did you manage to fix the problem? By copying the dependency? I haven't seen this solution ever before.

This is specific to ARM Docker deployments. The Ubuntu deployments in the Cloud don't seem to have this issue.

I found people having the similar issue after installing docker-compose - github.com/docker/docker-py/issues...


Tested today.
Raspberry pi 3B+ with Raspbian Buster Lite

I had to switch to python3/pip3 to install docker compose.
The message just before the error was:
setuptools requires Python '>=3.5' but the running Python is 2.7.16

1 = make python3 the default python => search google
2 = sudo apt-get install -y python3-pip "3" !!!
3 = sudo pip3 install docker-compose "3" !!!


Yep, got this error too and that indeed was the solution. The strange part is that it did worked, till about one or two weeks ago. Now I use this:

$ curl -sSL get.docker.com | sh
$ sudo usermod -aG docker pi
$ sudo apt-get install libffi-dev libssl-dev
$ sudo apt-get install -y python3 python3-pip
$ sudo apt-get remove python-configparser (apparently this isn't installed by using my commands on a clean install)
$ sudo pip3 install docker-compose


I just tested everything on a fresh Raspbian Buster build on a Raspberry Pi 3 B+ and it indeed needed a few changes.

sudo apt-get remove python-configparser

Thanks to @dbrosy and @vegasbrianc for pointing it out.


Tested on

Model: Raspberry Pi 4 Model B 4GBRAM
MicroSD: Sandisk 32GB
OS: Raspbian Buster with desktop
Flashed OS App: Balena Etcher

Thank you Rohan


Thanks for this, but I also had to install libssl-dev before the final sudo pip install docker-compose worked


I'll update the post to include this as well! Thanks! ๐Ÿ‘๐Ÿฝ


Boom! It's done. Anything more? ๐Ÿ˜‡


Thx for this post, Rohan! One possible thing to add - when I ran the command: sudo pip install docker-compose on my Raspberry Pi 4 running Ubuntu 19.10, I got the error:

ERROR: Cannot uninstall 'PyYAML'. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

After reading this thread - stackoverflow.com/questions/499115... - I was able to install docker-compose by adding the ignore-installed flag like this:

sudo pip install docker-compose --ignore-installed PyYAML

Note that during the install, I did see these 2 errors:
ERROR: launchpadlib 1.10.7 requires testresources, which is not installed.
ERROR: docker-compose 1.25.0 has requirement PyYAML<5,>=3.10, but you'll have pyyaml 5.1.2 which is incompatible.

but that didn't stop docker-compose from installing successfully, and now I have:

ubuntu@ubuntu:~$ docker-compose --version
docker-compose version 1.25.0, build b42d419

and I just manually ran sudo pip install testresources after. Hope this helps!


Oh, on Ubuntu 19?

I had not thought it would work with that. Cool that you manage to get it working!


also install python-dev / python3-dev


Ah, I had this already installed, so missed it. ๐Ÿ˜…


My docker-compose step fails as follows;
Exception: Version mismatch: this is the 'cffi' package version 1.13.2, located in '/tmp/pip-build-mJ6FCD/pynacl/cffi-1.13.2-py2.7-linux-armv7l.egg/cffi/api.pyc'. When we import the top-level '_cffi_backend' extension module, we get version 1.9.1, located in '/usr/lib/python2.7/dist-packages/_cffi_backend.arm-linux-gnueabihf.so'. The two versions should be equal; check your installation.

Any help appreciated.


sudo pip3 install cffi==1.13.2 solved but there are other dependencies.


Hi Rohan,

after step 1 i got the message back: status = stable.
When i enter step 2 ... i got back: usermod: group 'docker' doesnt exist

Please can you help me?


Hey Rob,

That is super weird. I just tried this with a fresh installation and I did not have any issues.

Does rebooting after installing docker help?


Hi, thanks for you post.

I'm starting to work with Docker and Docker-compose but can't install the docker-compose.

My configuration is:

  • RaspberryPi 3+
  • Raspbian Full Stretch and Buster (tried both with a clean install)

The hello-world docker runs without errors. So docker is installed.

But with the last command "sudo pip install docker-compose" There is an error end I don't know how too solve it. Looked around at the internet and trying Stretch and Buster version of Raspbian. Can you help me.

setuptools requires Python '>=3.5' but the running Python is 2.7.16

Command "/usr/bin/python -m pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-1XaNDC --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple --extra-index-url https://www.piwheels.org/simple -- setuptools>=40.8.0 wheel "cffi>=1.1; python_implementation != 'PyPy'"" failed with error code 1 in None

Thanks for this hint! I literally tried each and every approach I found. Installing the dependencies fixed my issue with docker-compose 1.25 on Raspberry Pi 4 and Ubuntu Server on it!

code of conduct - report abuse