Code review tried to get me to change it, but I only would if he could come up with something better. It moves the cursor ten pixels down, ten pixels right, ten pixels left, ten pixels up so that my UI tests don't hit page timeout when validating big pages of data. It's literally jiggling the mouse.
I'm a Systems Reliability and DevOps engineer for Netdata Inc. When not working, I enjoy studying linguistics and history, playing video games, and cooking all kinds of international cuisine.
My personal favorite was a function I came across almost a decade ago now named what_is_this_for() which, when passed a function that was a method of a class would return either the name of the class it was a method of, or "I have no idea!" if it couldn't find the class the method belonged to.
I don't remember anything else about the code base I saw it in (I can't even remember what language it was written in), but the sheer silliness of both needing a function that does that, and using that name for it (and that return value on a lookup failure) has always stuck with me.
DoMiracle(). Requirements were so vague that I didn't even know what it was supposed to do. So I named a stub as DoMiracle(). While waiting for clarification some documentation was created from the codebase. Once I got the requirement clarification, I was required to keep the name as DoMiracle since they didn't want to have to get signoff again on the documentation that had been generated.
Top comments (10)
My favorite in my own code is
jiggleMouse()
Code review tried to get me to change it, but I only would if he could come up with something better. It moves the cursor ten pixels down, ten pixels right, ten pixels left, ten pixels up so that my UI tests don't hit page timeout when validating big pages of data. It's literally jiggling the mouse.
Nice one! I imagined a (real) mouse jiggling xD
It's definitely a good name, I can't think of a better one at the moment.
My personal favorite was a function I came across almost a decade ago now named
what_is_this_for()
which, when passed a function that was a method of a class would return either the name of the class it was a method of, or"I have no idea!"
if it couldn't find the class the method belonged to.I don't remember anything else about the code base I saw it in (I can't even remember what language it was written in), but the sheer silliness of both needing a function that does that, and using that name for it (and that return value on a lookup failure) has always stuck with me.
utils.deepinsert() not sure how funny it is, but it sure sounds wrong xD
Found in our code base : VeryBadArchiFuckYouRunner.java ...
DoMiracle(). Requirements were so vague that I didn't even know what it was supposed to do. So I named a stub as DoMiracle(). While waiting for clarification some documentation was created from the codebase. Once I got the requirement clarification, I was required to keep the name as DoMiracle since they didn't want to have to get signoff again on the documentation that had been generated.
For me, it was
loadShit()
I sometimes mistakenly write
useMeme
instead ofuseMemo
.When i was building my project BugVilla, i did something like
Bug.findOne()
,Bug.removeMany()
Funny xD I have done the
useMemo
typo as well