Recently, I had a take home assignment for a front end role, and I had to make a sort of Dashboard. I thought I did everything right, but I was re...
Some comments have been hidden by the post's author - find out more
For further actions, you may consider blocking this person and/or reporting abuse
I agree with what @bubster said. You should rename it to "stop abusing".
Plus I did some benchmarking. It seems like if/else is always the slowest, using a Map makes only a negligible difference in Firefox, and an object is much faster in Chrome. Test for yourself: jsbench.me/jekur7m830/1
(I modified your code a little bit to keep things fair. You called toLowerCase for every branch in the first example and didn't use it in the latter two. I also moved the declaration of the object/Map out of the function, otherwise it would be created for every iteration)
When adding more calls like
to each test case if/else actually wins in Chrome which makes me think if Chrome somehow caches it.
At large scale a lookup by key is far more efficient. At small scale it is maybe small difference.
If you had extreme case of code of say 1000 branches of if else statements, at worst it takes 1000 attempts until the last one matches.
While looking up a value from an object/map by key is constant - only needed exactly one attempt to find the result.
Oh my bad for not using toLowerCase in further examples! Thanks for the tip about moving the dictionary out of the function.
You agreed with the tip, but the code example is still not updated. It's better to make the change, so beginners can learn from better examples.
Btw, my other comment was referring to "Thanks for the tip about moving the dictionary out of the function."
Have a lovely day.
Ah! Sweet coding challenges. I still remember this CTO who wanted me to replace an if else statement using a strategy pattern... the code was 10 lines. How to introduce useless complexity 101.
Why? I mean if it's so ugly, less readable, and error prone, why so many programming language implement them?
The first solution is NOT an object-oriented solution. You're using a JS "object" as a poor man's map of sorts but you're not using anything remotely OOP.
I love this post. It’s missing a bunch of details, such as how you can use functions instead of strings to match the items, and that this is a contemporary implementation of a “Command Pattern.”
Many of the responses aren’t terribly helpful, and some are a bit on the rude side. We should be more willing to entertain someone else’s ideas than to simply shoot them down as many comments on this post do.
Rishav, your idea could use more fleshing out, but I like where you’re going with this. I would very much like to see you continue on this thought, and address how this pattern can lead to a reduction in cyclomatic complexity and an overall increase in testability of the function implementing this pattern.
Thanks Michael, yes the comments are filled with useless people just wanting attention. Still thinking about this and surely will provide a better version in the future!
It's okay to go looking for better solutions than just a chained if-else. On the other hand, many evils have been committed in pursuit of over-optimization, merely on the basis of the feeling that "real developers don't use if statements". Oh yes, we use them. Often. And liberally. And they work really, really well.
See also...
Six Things You Thought Senior Devs Did (But We Don't)
Jason C. McDonald ・ May 21 '21 ・ 3 min read
You mean that developers have a tendency to overly-complicate simple problems by implementing 10 ton hammer solutions? Pshaw! Haha, for the rest of us "normies" simple, repeatable, digestible, straightforward solutions are always preferable to the "smart" solution.
This only works if you're comparing a single variable with known values. For other cases you've to use if/else
Can you share any example where you cannot make use of this?
I meant a real example from code. Anyways, we need to write good code in order to not add conditionals like these.
This is a perfectly fine example of real code lol.
Here:
@naveennamani is right. There are ways to do things with an array, but it can sometimes get over complicated and unreadable.
There are still elegant ways to handle that kind of requirement within the function:
And this translated to the initial
a
andb
example becomes:I see your point, but what if there is a property that is completely unrelated to the other variables? It would be pointless to do it for each one.
With lookup maps approach you can drill down how much you wantt with minimal changes to the initial structure, so it would be something like this:
Now you can go even further and have multiple validity checks for example:
And sorry for jumping in like so in the thread, I just know that plenty of people are for some reason struggling with this approach and I found this example intriguing. Also want to add that there is no practical way to completely avoid
if/else
statements, I use both approaches in my every day coding, it's just a matter of improving readability and removing code duplication.If there's a simple
0
and1
check, I see no reason to use a lookup map for that case, I'd just write down a simpleif
.This comment, and example is the best to explain the concept, thanks for this!
@davidlazic are you saying i should replace
with
sure those are equivalent, but what above the functionality that i intended to run in the if condition, should I wrap them in anonymous functions and pass to another function. What about the else if condition? Should I call that like
if(example('b', b))
?
If all conditions has some common logic you can use mapping to bring the variability into the object and using the mapped values to execute the logic. But again, even if slight deviation is added (for example a console log in a single else if condition) then your common logic is not common anymore, and you have to add more hacks like anonymous functions as part of the mapping object and so on, as you just demonstrated in your example with validation functions.
The best practical example would be state management in redux, where switch case statements seems to be most efficient, readable and manageable, try implementing that with mapping.
Hey @naveennamani , appreciate the time you've taken to think about this. My comment was a reply, not a statement, where I simply described how a specific problem could be written in a different kind of way with an example. Like I wrote, I use if/else, switch and this kind of approach on every day basis, based on the situation. If a function is supplied with too much logic, there's probably something that's gonna go wrong and it could be split into separate pure parts.
Are we just going to skip over the fact that
switch
exists? Lookup maps have neat uses, sure, but declaring a best practice for something without mentioning the intended language construct for it is a bit silly.Good point, and thanks for sharing. But I think it only depends on the case you are working on. if/else can be easily abused as of any other tool. So I think we should really know our tools, and pick the right one for the job.
Thanks for sharing again, keep it up
You probably don't even need any
else
if you go with the bouncer design pattern.I will still prefer switch here:
or object literals
else if
andMap
both work for your case, but they're not interchangeable in general - one is a control structure and the other one is a data structure.else if
is not inherently bad, it can be the most precise solution for some specific problems.I suggest watching videos or looking at the blog of Uncle Bob, the Clean Coder. He also supports this view.
He suggests another solution - polymorphism. Not needed for a simple case of matching string results but if you had more complex logic it would be worth making classes which all implement the same method. And then you pass in a class instance to a function and it calls the method of the class - no need for if statement or keylookup.
It's possible too outside of classes - but probably requires type system from TypeScript and overloading function so you call a variation of a function depending what type you pass in.
Despite the somewhere click-bait nature of the heading, I can’t help agreeing that a map sometimes looks like a better alternative for the “if/else” in terms of performance. Thanks for pointing on that!
neat approach to improving readability (and apparently also efficiency), I like!
small suggestion from my point of view, you called the valid characters object listOfCharacters but I would rather go with validCharacters or sth similiar. Since the variable is technically not a list
Can you share why would this be more readable/maintainable? I'm worried about you saying that this is "more readable and maintainable" without giving quality arguments about why that's true, that may let people believe that this is a must always.
I just went into a discussion about this topic, and some people argue that:
Is better than a simple if like:
This is an abuse/overuse of a language feature or structure which involves more concepts and more time on your brain in order to understand what is happening when you read it.
I also believe that this enlarge possible problems in devs minds like "Primitive types obsession" and "Declarative Dilussion", check:
WDYT?
well ... not really. There's the so-called object notation in JS and the definition of an object as per OOP, which on a higher level is the data represented + methods (any methods, regardless whether you implement encapsulation or not). An "object" { "foo": "bar" }; might be called an object in JS notation, but no in OOP as it lacks methods and a definition (eg: a class of which the object should be an instance of).
Well if you're going that deep, you should know that JavaScript is a prototype based object oriented language, rather than class based, but it still is object oriented, so technically yeah an object is js is an object in OOP
As long as you also define methods on the prototype, yes. Object oriented isn't just "call stuff objects". The core of OOP is the communication between objects, regardless of how they are implemented. Encapsulation, inheritance/composition, etc. JS very much an OOP language, but if it's not an instantiated structure according to the definition, it's not an OOP object.
I don't think replacing "if"/"else if"/"else" conditions with yours is the best.
There is reason we use these known conditions nowadays. It is easy to read. But you are right, it is not always easy to read. I would replace your so-called bad code (the first one of-course) with code which uses only "if" conditions. There is no need to use "else if" when the "if" ones would execute "return" statements.
good,jobs. This idea is very good. Dictionary way, okay. The usage scenario in this way is to switch between different branches according to the incoming value. At that time, if you don’t pass in a value, you need to switch to a different branch, how to do ?
Sorry, but I don't agree at least with your example. Why not a switch case?
That would also be almost like if else.
Almost how? Did you meseare the performance? Can you be more specific?
Stop telling me what to do
Stop telling me to stop telling you what to do.
😂😂😂😂😂😂😂 This is a good one ! Nice article mate.
Thanks for the tips today at work I remember I’ve see your article and that’s save my code of a bunch of if/else. ;)
I'm glad it helped, thank u :)
Interesting.. no one mentions the Minification proces, and how that optimizes your code.
The sample above doesn't need else since it returns... That's a pet peeve of mine...
Your improved version really is a lot nicer. Thank you for sharing the lesson.
Thanks a lot for reading!
Thank you