Unavoidable Notification

twitter logo github logo ・1 min read

I'm having an interesting issue with dev.to lately where I have a notification badge stating I have a new message, however when I go to check my messages, nothing is new.

Here's a screenshot of my having a notification:

Image_1

And here's my chat when I click on the paper airplane. You can see that the unread badge is gone, but there're no new messages:

Test2

After I go back to the home page, the unread notification is still present.

Is this only something on my end or is this a known issue?

2018/11/27 EDIT: I've since posted an issue on GitHub about this following the discussion with Ben in the comments: https://github.com/thepracticaldev/dev.to/issues/1210

twitter logo DISCUSS (8)
markdown guide
 

Sorry for this. If you open up your web console and visit /chat_channels?state=unopened you should be able to find the culprit. Visiting it should mark it unread.

 

No worries, things happen.

That said, I visited that URL and it seems the culprit is the mentors channel. However, I'm not in that group. What can I do to fix it?

Output:

[{"id":31201,"slug":"mentors","channel_name":"Mentors","channel_type":"invite_only","last_opened_at":"2018-10-13T03:27:22.619Z","last_message_at":"2018-11-18T15:16:00.595Z","adjusted_slug":"mentors","membership_id":79646,"description":"Chat amonst mentors"}]

Current_Channels

 

Hey @ben , sorry to tag you like this but I'm curious what I can do to fix this given my situation. If there's someone else or another way I should go about this, let me know.

Actually, should I create an issue on the repo and provide all the info I can?

Mention absolutely welcome.

Yes, an issue is welcome.

Are you still experiencing the issue. We pushed a patch which may have fixed it but it’s hard to get visibility into this.

Yeah, I'm still experiencing it.

I'll go ahead and file an issue on the repository with some details.

 

Do you try turning off & on again ?

really, clean cache, cookies, logout, login, open in private tab ...

 

Hmm this is most likely a bug. You might have a notification in a group, and the group might not be appearing in the "All" tab. What happens when you click the "group" tab?

Classic DEV Post from Apr 7

Native Lazy Loading for <img> and <iframe> is Coming to the Web

I'm really excited about the upcoming loading attribute in HTML. &lt;img src...

Devin W. Leaman profile image
Just another internet denizen who likes making things, usually with code.