DEV Community

loading...

Android dev.to app always offline

coreyja profile image Corey Alexander ・1 min read

Is anyone else having issues with the dev.to Android app?

I run the Android Betas and for the last I think 2ish days the dev.to Android app hasn't been working to me. It consistently has said that I'm offline and shows me the (awesome) offline drawing page

I can access dev via my browser, but the app hasn't been working.

Anyone else seeing this?

Is there anything I can share to help any debugging efforts?

Discussion (7)

pic
Editor guide
Collapse
andrewbrooks profile image
Andrew Brooks πŸ‘¨β€πŸ’»

I downloaded the app but honestly I enjoy the experience from just saving the mobile site to my home screen and using it as a progressive web app. Can't say I've had the offline issue though either way.

Collapse
kenhkelly profile image
Ken Kelly

The PWA works very well. That's what I do for storage space. Instagram is good too

Collapse
coreyja profile image
Corey Alexander Author

Ya that's what I did before the app came out, maybe that's what I'll back to.

Thanks for the input!

Collapse
ben profile image
Ben Halpern

Yeah this is a known issue, we haven’t gotten to the bottom of it. If anyone wants to check out the service worker file in our repo we’d love some input 😭

Collapse
coreyja profile image
Corey Alexander Author

Gotcha, at least it's a known issue!

I wasn't see this until a few days ago so maybe I'll take a gander at the source this weekend if I have some time!

Collapse
mister_frostee profile image
Mister Frostee

Yes, I was facing this too. To fix, just clear the app storage and open it again.

Collapse
nektro profile image